hg: hsx/hotspot-gc/hotspot: 7102044: G1: VM crashes with assert(old_end != new_end) failed: don't call this otherwise

bengt.rutisson at oracle.com bengt.rutisson at oracle.com
Mon Oct 31 02:41:08 PDT 2011


Changeset: 6fd81579526f
Author:    brutisso
Date:      2011-10-31 08:01 +0100
URL:       http://hg.openjdk.java.net/hsx/hotspot-gc/hotspot/rev/6fd81579526f

7102044: G1: VM crashes with assert(old_end != new_end) failed: don't call this otherwise
Summary: arrayOopDesc::max_array_length() should return a value that does not overflow a size_t if it is converted to bytes.
Reviewed-by: kvn, dholmes

! make/jprt.properties
! src/share/vm/oops/arrayOop.cpp
! src/share/vm/oops/arrayOop.hpp
! src/share/vm/prims/jni.cpp
! src/share/vm/utilities/quickSort.cpp
! test/Makefile



More information about the hotspot-gc-dev mailing list