Request for review: 8008368: Deprecate MaxGCMinorPauseMillis

Tao Mao tao.mao at
Tue Mar 5 13:02:26 PST 2013

A new webrev is updated according to your feedback.

Plus, what are the other deprecated GC flags you mentioned?


On 3/4/13 11:20 PM, John Cuthbertson wrote:
> Hi Tao,
> I would change the name of the new routine to 
> check_deprecated_gc_flags() and I would move the call to after the 
> check_deprecated_gcs().
> Other than the above it looks good.
> You may want to file an enhancement to move some the other deprecated 
> GC flags, for which we emit warnings, into the new routine.
> JohnC
> On 2/28/2013 11:17 AM, Tao Mao wrote:
>> 8008368: Deprecate MaxGCMinorPauseMillis
>> webrev:
>> changeset:
>> We don't need the distinction between MaxGCMinorPauseMillis and 
>> MaxGCPauseMillis. The MaxGCMinorPauseMillis flag was introduced as a 
>> backup measure in case one pause target for all types collections was 
>> not enough. As it has turned out it seems one pause target is enough. 
>> Thus, we should deprecate MaxGCMinorPauseMillis and give a warning 
>> when set.
>> testing:
>> passed JPRT test(sanity)

More information about the hotspot-gc-dev mailing list