Request for review: 8008368: Deprecate MaxGCMinorPauseMillis

Tao Mao tao.mao at oracle.com
Thu Mar 7 10:37:00 PST 2013


Thank you for review, John.
I'll create a new CR for it.

Tao

On 3/5/13 1:56 PM, John Cuthbertson wrote:
> Hi Tao,
>
> Looks OK to me.
>
> Examples would be:
>
> -XX:CMSParPromoteBlocksToClaim=
> -XX:ParallelGCOldGenAllocBufferSize=
>
> Basically there are a few GC flags that we accept in 
> Arguments::parse_each_vm_init_arg() just so that we can emit a warning 
> message. These would be reasonable candidates. You don't need to list 
> them all in the new CR - just list the kind of flag that is a good 
> candidate for adding into check_deprecated_gc_flags(), namely it's 
> accepted in Arguments::parse_each_vm_init_arg() just so as to emit a 
> warning.
>
> Thanks,
>
> JohnC
>
> On 3/5/2013 1:02 PM, Tao Mao wrote:
>> A new webrev is updated according to your feedback.
>> http://cr.openjdk.java.net/~tamao/8008368/webrev.01/
>>
>> Plus, what are the other deprecated GC flags you mentioned?
>>
>> Thanks.
>> Tao
>>
>> On 3/4/13 11:20 PM, John Cuthbertson wrote:
>>> Hi Tao,
>>>
>>> I would change the name of the new routine to 
>>> check_deprecated_gc_flags() and I would move the call to after the 
>>> check_deprecated_gcs().
>>>
>>> Other than the above it looks good.
>>>
>>> You may want to file an enhancement to move some the other 
>>> deprecated GC flags, for which we emit warnings, into the new routine.
>>>
>>> JohnC
>>>
>>> On 2/28/2013 11:17 AM, Tao Mao wrote:
>>>> 8008368: Deprecate MaxGCMinorPauseMillis
>>>> https://jbs.oracle.com/bugs/browse/JDK-8008368
>>>>
>>>> webrev:
>>>> http://cr.openjdk.java.net/~tamao/8008368/webrev.00/
>>>>
>>>> changeset:
>>>> We don't need the distinction between MaxGCMinorPauseMillis and 
>>>> MaxGCPauseMillis. The MaxGCMinorPauseMillis flag was introduced as 
>>>> a backup measure in case one pause target for all types collections 
>>>> was not enough. As it has turned out it seems one pause target is 
>>>> enough. Thus, we should deprecate MaxGCMinorPauseMillis and give a 
>>>> warning when set.
>>>>
>>>> testing:
>>>> passed JPRT test(sanity)
>>>>
>>>
>


More information about the hotspot-gc-dev mailing list