Request for review: 8008368: Deprecate MaxGCMinorPauseMillis

Tao Mao tao.mao at oracle.com
Thu Mar 7 10:37:15 PST 2013


Thank you for review, Bengt.
I'll create a new CR for it.

Tao

On 3/5/13 11:01 PM, Bengt Rutisson wrote:
>
> Hi Tao,
>
> Looks good to me. Thanks for fixing this!
>
> As for other GC flags that are deprecated we could potentially move 
> the check for CMSIncrementalMode from check_deprecated_gcs() into your 
> new check_deprecated_gc_flags().
>
> 1821   if (CMSIncrementalMode) {
> 1822     warning("Using incremental CMS is deprecated and will likely 
> be removed in a future release");
> 1823   }
>
> But I don't think you have to do that now.
>
> Thanks,
> Bengt
>
> On 3/5/13 10:02 PM, Tao Mao wrote:
>> A new webrev is updated according to your feedback.
>> http://cr.openjdk.java.net/~tamao/8008368/webrev.01/
>>
>> Plus, what are the other deprecated GC flags you mentioned?
>>
>> Thanks.
>> Tao
>>
>> On 3/4/13 11:20 PM, John Cuthbertson wrote:
>>> Hi Tao,
>>>
>>> I would change the name of the new routine to 
>>> check_deprecated_gc_flags() and I would move the call to after the 
>>> check_deprecated_gcs().
>>>
>>> Other than the above it looks good.
>>>
>>> You may want to file an enhancement to move some the other 
>>> deprecated GC flags, for which we emit warnings, into the new routine.
>>>
>>> JohnC
>>>
>>> On 2/28/2013 11:17 AM, Tao Mao wrote:
>>>> 8008368: Deprecate MaxGCMinorPauseMillis
>>>> https://jbs.oracle.com/bugs/browse/JDK-8008368
>>>>
>>>> webrev:
>>>> http://cr.openjdk.java.net/~tamao/8008368/webrev.00/
>>>>
>>>> changeset:
>>>> We don't need the distinction between MaxGCMinorPauseMillis and 
>>>> MaxGCPauseMillis. The MaxGCMinorPauseMillis flag was introduced as 
>>>> a backup measure in case one pause target for all types collections 
>>>> was not enough. As it has turned out it seems one pause target is 
>>>> enough. Thus, we should deprecate MaxGCMinorPauseMillis and give a 
>>>> warning when set.
>>>>
>>>> testing:
>>>> passed JPRT test(sanity)
>>>>
>>>
>


More information about the hotspot-gc-dev mailing list