Request for review: 8016302: Change type of the number of GC workers to unsigned int (2)

Vladimir Kempik vladimir.kempik at oracle.com
Thu Sep 19 03:00:36 PDT 2013


Hi all,

Could I have a couple of reviews for this change?

http://cr.openjdk.java.net/~vkempik/8016302/webrev.00/

In 7121618 variables representing GC workers (worker id, worker id 
offset) have been changed from int to unsigned int.

Since then, code reintroduced the use of int's for this type of 
variable; fixing this by aligning the code to use uints for ints.

Thanks,
Vladimir



More information about the hotspot-gc-dev mailing list