RFR (XS): 8055091: CollectedHeap::_reserved usage should be cleaned up

Jesper Wilhelmsson jesper.wilhelmsson at oracle.com
Mon Aug 18 13:00:13 UTC 2014


With the changes suggested by Mikael this looks good.
Ship it!
/Jesper

Marcus Larsson skrev 18/8/14 11:04:
> Hi,
>
> On 08/18/2014 10:52 AM, Mikael Gerdin wrote:
>> Hi Marcus,
>>
>> On 2014-08-18 09:35, Marcus Larsson wrote:
>>> Hi,
>>>
>>> Can I have reviews for this small change to make the _reserved field of
>>> CollectedHeap private, unifying its initialization in a protected method.
>>>
>>> CR:
>>> http://cr.openjdk.java.net/~mgerdin/mlarsson/webrev-8055091/
>>
>> This looks good, but can you please rename set_reserved_region to
>> initialize_reserved_region to signal that it should only be called once. I
>> don't need to re-review the name change.
> I will do that.
> Thank you for reviewing.
>
>>
>> /Mikael
>>
>>>
>>> Bug:
>>> https://bugs.openjdk.java.net/browse/JDK-8055091
>>>
>>> Testing:
>>> jprt
>>>
>>> Thanks,
>>> Marcus
>


More information about the hotspot-gc-dev mailing list