RFR: 8048269: Add flag to turn off class unloading after G1 concurrent mark

Jon Masamitsu jon.masamitsu at oracle.com
Thu Jul 10 23:11:57 UTC 2014


Could we use a more GC generic name for the flag such as
GCClassUnloadingEnabled instead of a G1 specific name and
at some point move CMS to use the GC generic name?

Jon

On 07/10/2014 08:19 AM, Stefan Karlsson wrote:
> Hi all,
>
> Please, review this patch to add code and a flag to turn off class 
> unloading after G1 concurrent mark.
>
> http://cr.openjdk.java.net/~stefank/8048269/webrev.00/
> https://bugs.openjdk.java.net/browse/JDK-8048269
>
> thanks,
> StefanK



More information about the hotspot-gc-dev mailing list