RFR [1/2] 8065358: JDK-8065218 Move CMS-specific fields from Space to CompactibleFreeListSpace
sangheon.kim at oracle.com
Thu Nov 20 16:56:40 UTC 2014
One question about a function/variable name.
I know the original names are using upper/lower-cases but according to
hotspot coding style, only lower-case are recommended for
As it seems easy to change, how about changing them?
On 11/20/2014 12:46 AM, Mikael Gerdin wrote:
> Hi all,
> This is the first patch of two to fix JDK-8065358.
> In this change I suggest that we move a field used only by CMS to
> CompactibleFreeListSpace and introduce a virtual getter in the Space
> base class.
> I estimate that the performance impact of the virtual call will be
> small since the getter path already does several virtual calls.
> Moving the field will allow me to add another field to G1's
> G1OffsetTableContigSpace in patch [2/2] without introducing a
> footprint regression.
> Webrev: http://cr.openjdk.java.net/~mgerdin/8065218/webrev.0/
> Bug: https://bugs.openjdk.java.net/browse/JDK-8065218
> Parent bug: https://bugs.openjdk.java.net/browse/JDK-8065358
> Testing: JPRT
More information about the hotspot-gc-dev