RFR [1/2] 8065358: JDK-8065218 Move CMS-specific fields from Space to CompactibleFreeListSpace

Mikael Gerdin mikael.gerdin at oracle.com
Wed Nov 26 09:50:35 UTC 2014


Hi Sangheon,

On 2014-11-20 17:56, Sangheon Kim wrote:
> Hi Mikael,
>
> Looks good.
>
> One question about a function/variable name.
> I know the original names are using upper/lower-cases but according to
> hotspot coding style, only lower-case are recommended for
> function/variable names.
> As it seems easy to change, how about changing them?

Although I agree with you in principle, most of compactibleFreeListSpace 
uses camelCase rather than underscore-separated lower-case so I'd rather 
keep it the way it is in order to not make it even more inconsistent 
with itself.

/Mikael

>
> Thanks,
> Sangheon
>
>
> On 11/20/2014 12:46 AM, Mikael Gerdin wrote:
>> Hi all,
>>
>> This is the first patch of two to fix JDK-8065358.
>>
>> In this change I suggest that we move a field used only by CMS to
>> CompactibleFreeListSpace and introduce a virtual getter in the Space
>> base class.
>>
>> I estimate that the performance impact of the virtual call will be
>> small since the getter path already does several virtual calls.
>>
>> Moving the field will allow me to add another field to G1's
>> G1OffsetTableContigSpace in patch [2/2] without introducing a
>> footprint regression.
>>
>> Webrev: http://cr.openjdk.java.net/~mgerdin/8065218/webrev.0/
>> Bug: https://bugs.openjdk.java.net/browse/JDK-8065218
>> Parent bug: https://bugs.openjdk.java.net/browse/JDK-8065358
>> Testing: JPRT
>>
>> Thanks
>> /Mikael
>


More information about the hotspot-gc-dev mailing list