RFR (S): 8133047: Rename G1ParScanThreadState::_queue_num to _worker_id

Jesper Wilhelmsson jesper.wilhelmsson at oracle.com
Wed Aug 5 14:26:00 UTC 2015

Looks good.

There is another use of queue_num in 
G1CollectedHeap::preserve_mark_during_evac_failure(). Was that one intentionally 


Thomas Schatzl skrev den 5/8/15 14:40:
> Hi all,
>    can I have reviews for this small cleanup that renames the
> G1ParScanThreadState::_queue_num member to worker_id like it is called
> for all members that have the same functionality.
> G1ParScanThreadState::_queue_num is actually compared to a worker_id
> member of another class, and assigned to a _worker_id member somewhere
> else in the code.
> It hopefully makes the code slightly easier to read in the future by not
> using different names for the same thing throughput the code.
> CR:
> https://bugs.openjdk.java.net/browse/JDK-8133047
> Webrev:
> http://cr.openjdk.java.net/~tschatzl/8133047/webrev/
> testing:
> jprt
> Thanks,
>    Thomas

More information about the hotspot-gc-dev mailing list