RFR (S): 8133047: Rename G1ParScanThreadState::_queue_num to _worker_id

Thomas Schatzl thomas.schatzl at oracle.com
Wed Aug 5 14:35:06 UTC 2015


On Wed, 2015-08-05 at 16:26 +0200, Jesper Wilhelmsson wrote:
> Looks good.
> There is another use of queue_num in 
> G1CollectedHeap::preserve_mark_during_evac_failure(). Was that one intentionally 
> left?

Overlooked, the code was not in G1ParScanThreadState so I did not look.
I do think that again worker id is expected here.

New webrevs:
http://cr.openjdk.java.net/~tschatzl/8133047/webrev.1 (full)
http://cr.openjdk.java.net/~tschatzl/8133047/webrev.0_to_1 (diff)


More information about the hotspot-gc-dev mailing list