RFR: 8051984: @ignore should be placed after @test
bengt.rutisson at oracle.com
Mon Feb 16 15:41:28 UTC 2015
On 16/02/15 16:24, Andrey Zakharov wrote:
>> But JDK-8019361 looks like a wrong number. It must be JDK-8051984, I think.
> I'm wrongly got reason of ignore bug for RFR. Thanks, Dima.
>> If so, what about other sources listed in the description:
> Its already fixed either by removing @ignore either by inserting @requires
>> Why did you change the static import of
>> com.oracle.java.testlibrary.Asserts? Seems unrelated to the @ignore
>> change and I don't think there is a reason for it either. We use static
>> import of the asserts a lot in our test code.
>> />/ Thanks./
> There is nothing especial in import static here, its only serves to
> reduce Asserts package names in code, but it also leads to less
> readability and question like "what assertLessThan comes from?".
> Asserts.assertLessThan is better - it doesn't junk global namespace.
> In only this case - its only code style question. If you have any
> other conserns about this, please tell me.
For people reading the hotspots tests a lot I think assertLessThan() is
more readable than Asserts.assertLessThan(). Please don't change this
for this test only. If you feel strongly about this issue I think you
should bring it up for a wider discussion so we can agree on a guideline
for how to use it. Right now it just seems like a completely unrelated
change that is not necessary to solve your bug.
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the hotspot-gc-dev