RFR (S): 8073052: Rename and clean up the allocation manager hierarchy in g1Allocator.?pp
jon.masamitsu at oracle.com
Sun Mar 29 19:35:33 UTC 2015
It's not clear to me that the name change
G1ParGCAllocBuffer to G1PLAB is a change for the better.
From the base class name ParGCAllocBuffer, I could guess
the G1 version is G1ParGCAllocBuffer but I would not guess
G1PLAB. Can you motivate that name (G1PLAB) for me?
On 3/23/2015 8:02 AM, Thomas Schatzl wrote:
> Hi Kim, Sangheon, Stefan,
> thanks for your reviews.
> I still need a Reviewer review for this. I will fix Sangheon's comment
> about the copyright date with the push if you do not object.
> On Thu, 2015-03-19 at 13:15 -0400, Kim Barrett wrote:
>> On Mar 18, 2015, at 6:37 AM, Thomas Schatzl <thomas.schatzl at oracle.com> wrote:
>>> Hi Stefan, Kim,
>>> could you look at the updated CR again? Also, I need a Reviewer to
>>> look at this.
>>> On Mon, 2015-03-09 at 12:02 +0100, Thomas Schatzl wrote:
>>>> Hi Stefan,
>>>> thanks for the review.
>>>> There is a new webrev at
>>>> http://cr.openjdk.java.net/~tschatzl/8073052/webrev.2 (full)
>>>> http://cr.openjdk.java.net/~tschatzl/8073052/webrev.1_to_2 (diff)
>> Sorry about losing track of this.
>> New version looks good.
More information about the hotspot-gc-dev