RFR (S): 8073052: Rename and clean up the allocation manager hierarchy in g1Allocator.?pp
thomas.schatzl at oracle.com
Tue Mar 31 07:32:34 UTC 2015
On Sun, 2015-03-29 at 12:35 -0700, Jon Masamitsu wrote:
> It's not clear to me that the name change
> G1ParGCAllocBuffer to G1PLAB is a change for the better.
> From the base class name ParGCAllocBuffer, I could guess
> the G1 version is G1ParGCAllocBuffer but I would not guess
> G1PLAB. Can you motivate that name (G1PLAB) for me?
"PLAB" is a commonly used and more concise abbreviation for this kind of
data structure. We ourselves use "Promotion Local Allocation
Buffer" (sometimes also "Parallel Local...") e.g. in the description of
the *PLAB* switches. Also in literature (see some GC papers) that name
is used for this kind of data structure (note that they apparently use
ParGCAllocBuffer misses the information about it being about
"promotion"/"parallel" and "local" too, and is longer to type.
I think it is prudent to follow existing naming for stuff like that
instead of re-inventing it within the same code.
More information about the hotspot-gc-dev