RFR: 8142390: Move ScanRSClosure to header file

Thomas Schatzl thomas.schatzl at oracle.com
Wed Nov 11 14:09:20 UTC 2015


On Tue, 2015-11-10 at 11:55 +0100, Erik Helin wrote:
> Hi all,
> 
> this small patches move the declaration of ScanRSClosure from
> g1RemSet.cpp to g1RemSet.hpp.
> 
> Enhancement:
> https://bugs.openjdk.java.net/browse/JDK-8142390
> 
> Webrev:
> http://cr.openjdk.java.net/~ehelin/8142390/webrev.00/
> 
> Testing:
> JPRT

  looks good, apart from the name mismatch of the "cards_looked_up"
getter and the member variable. Would be nice for them to be the same.

Thanks,
  Thomas




More information about the hotspot-gc-dev mailing list