RFR: 8142390: Move ScanRSClosure to header file

Erik Helin erik.helin at oracle.com
Wed Nov 11 14:37:23 UTC 2015


On 2015-11-11, Thomas Schatzl wrote:
> On Tue, 2015-11-10 at 11:55 +0100, Erik Helin wrote:
> > Hi all,
> > 
> > this small patches move the declaration of ScanRSClosure from
> > g1RemSet.cpp to g1RemSet.hpp.
> > 
> > Enhancement:
> > https://bugs.openjdk.java.net/browse/JDK-8142390
> > 
> > Webrev:
> > http://cr.openjdk.java.net/~ehelin/8142390/webrev.00/
> > 
> > Testing:
> > JPRT
> 
>   looks good, apart from the name mismatch of the "cards_looked_up"
> getter and the member variable. Would be nice for them to be the same.

Thanks for the review Thomas! Please see my reply to Jon regarding the
naming.

Thanks,
Erik

> Thanks,
>   Thomas
> 
> 


More information about the hotspot-gc-dev mailing list