RFR: 8142390: Move ScanRSClosure to header file

Jon Masamitsu jon.masamitsu at oracle.com
Wed Nov 11 23:40:14 UTC 2015



On 11/11/2015 6:36 AM, Erik Helin wrote:
> On 2015-11-10, Jon Masamitsu wrote:
>> Change looks good.
>>
>> Reviewed.
>>
>> Would you consider in this patch changing
>>
>> 185 size_t cards_looked_up() { return _cards;} _cards -> _cards_looked_up or
>> changing cards_looked_up() -> cards()
>>
>> Your call.  I don't need a new webrev.
> Thanks for the review Jon! In order to have this patch only be about
> moving code, is it ok if I send out a new patch that renames (and also
> makes the method const)?

That would be fine.  Sorry I didn't get back earlier.

Jon

>
> Thanks,
> Erik
>
>> Jon
>>
>>
>> On 11/10/2015 02:55 AM, Erik Helin wrote:
>>> Hi all,
>>>
>>> this small patches move the declaration of ScanRSClosure from
>>> g1RemSet.cpp to g1RemSet.hpp.
>>>
>>> Enhancement:
>>> https://bugs.openjdk.java.net/browse/JDK-8142390
>>>
>>> Webrev:
>>> http://cr.openjdk.java.net/~ehelin/8142390/webrev.00/
>>>
>>> Testing:
>>> JPRT
>>>
>>> Thanks,
>>> Erik



More information about the hotspot-gc-dev mailing list