RFR: 8144075: Move prepare_for_oops_into_collection_set_do into pre_evacuate_collection_set

Thomas Schatzl thomas.schatzl at oracle.com
Wed Nov 25 19:19:30 UTC 2015


Hi,

On Wed, 2015-11-25 at 19:31 +0100, Erik Helin wrote:
> Hi all,
> 
> this tiny patch just move the call to
> g1_rem_set()->prepare_for_oops_into_collection_set_do() into
> G1CollectedHeap::pre_evacuate_collection_set, instead of having it
> in evacuate_collection_set. As the name of the method suggests,
> prepare_for_oops_into_collection_set_do is more about preparation for
> the evacuation than about the actual evacuation.
> 
> Bug:
> https://bugs.openjdk.java.net/browse/JDK-8144075
> 
> Webrev:
> http://cr.openjdk.java.net/~ehelin/8144075/webrev.00/
> 
> Testing:
> - GC test suite with full verification.

  looks good.

Thomas




More information about the hotspot-gc-dev mailing list