RFR: 8144077: Add getter for G1CollectorPolicy::_collectionSetChooser

Thomas Schatzl thomas.schatzl at oracle.com
Thu Nov 26 09:08:29 UTC 2015


Hi,

On Wed, 2015-11-25 at 19:56 +0100, Erik Helin wrote:
> Hi all,
> 
> this small patch just introduces a getter for
> G1CollectorPolicy::_collectionSetChooser in order to make the code in
> G1CollectorPolicy slightly less verbose.
> 
> Bug:
> https://bugs.openjdk.java.net/browse/JDK-8144077
> 
> Webrev:
> http://cr.openjdk.java.net/~ehelin/8144077/webrev.00/
> 
> Testing:
> - GC test suite with full verification.

  could you also rename _collectionSetChooser using the standard naming
conventions while you are there? I would be fine with _cset_chooser.

Looks good otherwise.

Thanks,
  Thomas



More information about the hotspot-gc-dev mailing list