RFR: 8144077: Add getter for G1CollectorPolicy::_collectionSetChooser
mikael.gerdin at oracle.com
Thu Nov 26 09:10:18 UTC 2015
On 2015-11-26 10:08, Thomas Schatzl wrote:
> On Wed, 2015-11-25 at 19:56 +0100, Erik Helin wrote:
>> Hi all,
>> this small patch just introduces a getter for
>> G1CollectorPolicy::_collectionSetChooser in order to make the code in
>> G1CollectorPolicy slightly less verbose.
>> - GC test suite with full verification.
> could you also rename _collectionSetChooser using the standard naming
> conventions while you are there? I would be fine with _cset_chooser.
Just FTR, that's ok with me as well.
> Looks good otherwise.
More information about the hotspot-gc-dev