RFR: 8144077: Add getter for G1CollectorPolicy::_collectionSetChooser

Erik Helin erik.helin at oracle.com
Thu Nov 26 12:59:53 UTC 2015


On 2015-11-26, Mikael Gerdin wrote:
> On 2015-11-26 10:08, Thomas Schatzl wrote:
> >Hi,
> >
> >On Wed, 2015-11-25 at 19:56 +0100, Erik Helin wrote:
> >>Hi all,
> >>
> >>this small patch just introduces a getter for
> >>G1CollectorPolicy::_collectionSetChooser in order to make the code in
> >>G1CollectorPolicy slightly less verbose.
> >>
> >>Bug:
> >>https://bugs.openjdk.java.net/browse/JDK-8144077
> >>
> >>Webrev:
> >>http://cr.openjdk.java.net/~ehelin/8144077/webrev.00/
> >>
> >>Testing:
> >>- GC test suite with full verification.
> >
> >   could you also rename _collectionSetChooser using the standard naming
> >conventions while you are there? I would be fine with _cset_chooser.
> 
> Just FTR, that's ok with me as well.

Mikael, Thomas,

thanks for the reviews! I will do the renaming before I push.

Thanks,
Erik

> /Mikael
> 
> >
> >Looks good otherwise.
> >
> >Thanks,
> >   Thomas
> >
> 


More information about the hotspot-gc-dev mailing list