RFR: 8148973: Rename g1/concurrentMark.{hpp,cpp,inline.hpp} to g1/g1ConcurrentMark.{hpp,cpp,inline.hpp}

Erik Helin erik.helin at oracle.com
Thu Feb 4 08:36:54 UTC 2016


Hi all,

this patch renames the files g1/concurrentMark.{hpp,cpp,inline.hpp} to
g1/g1ConcurrentMark.{hpp,cpp,inline.hpp} (the prefix g1 is added). The
classes in files have also been prefixed with G1 where it makes sense
(e.g. ConcurrentMark is now G1ConcurrentMark).

Webrev:
http://cr.openjdk.java.net/~ehelin/8148973/00/

Testing:
- JPRT
- Using grep to verify that the names of the old classes are no longer
  used (not even in comments).

Thanks,
Erik


More information about the hotspot-gc-dev mailing list