RFR (M) JDK-8151178: Move the collection set out of the G1 collector policy

Thomas Schatzl thomas.schatzl at oracle.com
Mon Mar 7 14:50:39 UTC 2016


Hi,

On Mon, 2016-03-07 at 15:32 +0100, Mikael Gerdin wrote:
> Hi Thomas,
> 
> > On 2016-03-07 15:25, Thomas Schatzl wrote:Hi Mikael,
> > 
> > On Mon, 2016-03-07 at 10:46 +0100, Mikael Gerdin wrote:
> > > Hi all,
> > > 
> > > Here's a new version of the webrev based on feedback from Jesper 
> > > and Tom.
> > > 
> > > http://cr.openjdk.java.net/~mgerdin/8151178/version2/
> > > 
> > > The incremental layout is similar to version1, with the addition 
> > > of webrev_4 which contains the review changes.
> > > 
> > > In this update I also took the liberty to change G1CollectionSet 
> > > to become a value member in G1CollectedHeap instead of a 
> > > separately C-heap allocated object. I see no value in it being 
> > > allocated separately.
> > 
> >    some minor issues:
> 
[...]
> 
> 
> Hm, yeah I was torn on naming this. On one hand we usually name 
> accessors after the member variable name. On the other hand I agree
> that 
> set_g1p is not a nice name. I also thought about "initialize" or 
> something, but that makes it sound like it does a lot more.
> 
> Maybe I should just rename it _policy an have a set_policy?

That would be nice.

> > - as a future cleanup suggestion, maybe the CollectionSetChooser 
> > could be one of the first targets, and probably hidden from direct 
> > access by the G1CollectorPolicy. Not sure.
> 
> It might be possible, but it's not on my refactor list at this time, 
> unfortunately.

Not a priority.

Thanks,
  Thomas



More information about the hotspot-gc-dev mailing list