RFR: JDK-8151605: Change warning() to log_warning(gc) in the GC code

Jon Masamitsu jon.masamitsu at oracle.com
Thu Mar 10 17:53:30 UTC 2016


Need copyright updates

src/share/vm/gc/shared/cardTableRS.cpp
src/share/vm/gc/shared/generation.hpp
src/share/vm/gc/shared/vmGCOperations.cpp
src/share/vm/gc/cms/concurrentMarkSweepThread.cpp
src/share/vm/gc/g1/g1CollectedHeap.cpp
src/share/vm/gc/parallel/gcTaskThread.cpp
|| src/share/vm/gc/shared/cardGeneration.cpp

Otherwise, look good.

Jon
**
**
On 03/10/2016 02:00 AM, Bengt Rutisson wrote:
>
> Hi everyone,
>
> Could I have a couple of reviews for this change?
>
> https://bugs.openjdk.java.net/browse/JDK-8151605
> http://cr.openjdk.java.net/~brutisso/8151605/webrev.00/
>
> With the new logging framework we should use log_warning() instead of 
> warning().
>
> Thanks,
> Bengt

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.openjdk.java.net/pipermail/hotspot-gc-dev/attachments/20160310/561a9eb3/attachment-0001.html>


More information about the hotspot-gc-dev mailing list