RFR (S): 8151614: Improve logging in concurrent mark code

Bengt Rutisson bengt.rutisson at oracle.com
Fri Mar 11 14:19:57 UTC 2016

Hi Thomas,

On 2016-03-10 18:02, Thomas Schatzl wrote:
> Hi all,
>    can I have reviews for this change that improves the logging code for
> concurrent mark by:
> - removes the need to have two scoped objects, one for logging, one for
> JFR for every phase
> - tries to make the phase names correspond to method names
> - add a "marking" tag to marking related log messages

I don't really like the addition of the "marking" tag. It means that if 
you run with -Xlog:gc you don't get any logging about the concurrent 
cycle. This log configuration is supposed to be similar to the old 
-XX:+PrintGC, which I think should give at least some relevant 
information about each GC - including the concurrent cycle.

> - removes a duplicate log message ("Restart for overflow") at different
> levels
> CR:
> https://bugs.openjdk.java.net/browse/JDK-8151614
> Webrev:
> http://cr.openjdk.java.net/~tschatzl/8151614/webrev/

In the G1ConcPhaseTimer class you can use the LOG_TAGS macro to get a 
bit more readable code. Chaning:

      GCTraceConcTimeImpl<LogLevel::Info,  LogTag::_gc, 


      GCTraceConcTimeImpl<LogLevel::Info,  LOG_TAGS(gc, marking)>(title),

But then again, I am not sure we want the "marking" tag here.


> Testing:
> jprt
> Thanks,
>    Thomas

More information about the hotspot-gc-dev mailing list