RFR: 8166663: Simplify oops_on_card_seq_iterate_careful interface
kim.barrett at oracle.com
Mon Sep 26 18:31:52 UTC 2016
> On Sep 26, 2016, at 8:09 AM, Mikael Gerdin <mikael.gerdin at oracle.com> wrote:
> On 2016-09-26 10:06, Thomas Schatzl wrote:
>> Hi Kim,
>> On Sun, 2016-09-25 at 19:57 -0400, Kim Barrett wrote:
>>> Please review this simplification of the interface and implementation
>>> of HeapRegion::oops_on_card_seq_iterate_careful.
>>> JPRT, local jtreg hotspot_all
>> - please add braces around the statement in the statement executed
>> when the boolean expression is true in line 369 heapRegion.cpp.
>> - maybe add a sentence like "Iterate over the the card in the card
>> table specified by card_ptr/mr, applying cl on all references." at the
>> description in line 656 in heapRegion.hpp. Or just try to make the
>> description a bit more readable.
>> In any case I do not need re-review for either trivial change.
> I'm fine with this change including Thomas' suggestions above.
Thanks, Thomas and Mikael.
More information about the hotspot-gc-dev