RFR (S/M): 8149127: Rename g1/concurrentMarkThread.* to g1/g1ConcurrentMarkThread.*

Thomas Schatzl thomas.schatzl at oracle.com
Mon Nov 6 07:47:01 UTC 2017


Hi Sangheon, Stefan,

On Fri, 2017-11-03 at 16:20 -0700, sangheon.kim wrote:
> Hi Thomas,
> 
> On 11/03/2017 06:47 AM, Thomas Schatzl wrote:
> > 
[...]
> > > Looks really good. Just one small thing, could you rename the
> > > getter in G1CollectedHeap:
> > > 1392   G1ConcurrentRefine* concurrent_g1_refine() const { return
> > > _cg1r; }
> > > 
> > > I think it would make sense to rename it to
> > > g1_concurrent_refine().
> > > 
> > 
> >    renamed to concurrent_refine() - also renamed the few "cg1r"
> > names
> > floating around for consistency.
> > 
> > http://cr.openjdk.java.net/~tschatzl/8149127/webrev.1/ (full)
> > http://cr.openjdk.java.net/~tschatzl/8149127/webrev.b.1 (which also
> > represents the 0_to_1 patch)
> 
> Looks good.
> Nice cleanup!

  thanks for your reviews.

Thomas



More information about the hotspot-gc-dev mailing list