RFR (S): 8154528: Reclaim regions emptied by marking in Remark pause
stefan.johansson at oracle.com
Wed Apr 4 08:40:28 UTC 2018
On 2018-04-03 17:08, Thomas Schatzl wrote:
> On Tue, 2018-04-03 at 14:53 +0200, Stefan Johansson wrote:
>> Thanks for yet another nice improvement of G1 Thomas,
>> On 2018-03-29 16:49, Thomas Schatzl wrote:
>>> Hi all,
>>> can I have reviews for this change that moves the space
>>> reclamation of empty regions into the Remark pause, which makes
>>> these regions available much sooner than before, with the obvious
>>> benefits of doing so.
>> The change looks good, but I realized that reclaim_empty_regions()
>> uses a task named G1CleanupTask. This naming is a bit unfortunate now
>> since this is not the cleanup phase anymore, but still correct since
>> we are doing cleanup. What do you think about renaming it to
>> G1CleanRegionTask or G1ReclaimRegionTask? I also see that "cleanup"
>> ripples down a bit but I don't think we need to change that. I'm fine
>> with not doing anything at all but if you dislike the suggestion, but
>> I wanted to raise the question.
> What about G1ReclaimRegionsTask? Here's a webrev just doing that:
> http://cr.openjdk.java.net/~tschatzl/8154528/webrev.0_to_1/ (diff)
> http://cr.openjdk.java.net/~tschatzl/8154528/webrev.1/ (full)
That's good, reviewed!
More information about the hotspot-gc-dev