RFR (S): 8202021: Improve variable naming in ReferenceProcessor

Thomas Schatzl thomas.schatzl at oracle.com
Thu Apr 19 19:01:04 UTC 2018


Hi all,

  can I have reviews for this cleanup change that improves variable
naming in ReferenceProcessor code.

The main change is about renaming some member variables from something
really confusing to me to something useful (to me again :)) in the
DiscoveredListIterator class.

The other change is related to changing ReferenceProcessor::num_q to
num_queues, i.e. spelling out what the "q" is supposed to mean.

That imho improves readability quite a bit.

CR:
https://bugs.openjdk.java.net/browse/JDK-8202021
Webrev:
http://cr.openjdk.java.net/~tschatzl/8202021/webrev/
Testing:
local compilation, hs-tier1-4 with 8202017

based on JDK-8202018, but I do not think there is overlap.

Thanks,
  Thomas



More information about the hotspot-gc-dev mailing list