RFR (XS): 8203262: Incorrect cmpxchg usage in MetaspaceGC::inc_capacity_until_GC

Thomas Schatzl thomas.schatzl at oracle.com
Sun May 20 15:34:59 UTC 2018


Hi Aleksey,

On Sun, 2018-05-20 at 11:07 +0200, Aleksey Shipilev wrote:
> On 05/20/2018 10:04 AM, Thomas Schatzl wrote:
> > Webrev:
> > http://cr.openjdk.java.net/~tschatzl/8203262/webrev
> 
> Looks good.

  thanks for your review...

> 
> I would probably rename "old_capacity_until_GC" to just "old_value"
> to reduce noise and provide
> visible symmetries. And avoided "actual" because it is confusing --
> it is not an actual value anymore :)

  I updated the webrev in place.

Thanks,
  Thomas



More information about the hotspot-gc-dev mailing list