RFR: 8213352: Separate BufferNode allocation from PtrQueueSet

Kim Barrett kim.barrett at oracle.com
Thu Nov 15 20:57:00 UTC 2018


> On Nov 15, 2018, at 11:56 AM, Stefan Johansson <stefan.johansson at oracle.com> wrote:
> 
> Hi Kim,
> 
> On 2018-11-08 00:55, Kim Barrett wrote:
>>> On Nov 7, 2018, at 6:22 PM, Thomas Schatzl <thomas.schatzl at oracle.com> wrote:
>>> 
>>> Hi,
>>> 
>>> On Sun, 2018-11-04 at 23:51 -0500, Kim Barrett wrote:
>>>> Please review this change to PtrQueue buffer allocation, moving the
>>>> implementation of free-list based allocation from PtrQueueSet to a
>>>> separate BufferNode::Allocator object.  The old code supported
>>>> sharing
>>>> of free-lists by having one PtrQueueSet delegate to another; now
>>>> free-list sharing is provided by using the same allocator object.
>>>> 
>>>> CR:
>>>> https://bugs.openjdk.java.net/browse/JDK-8213352
>>>> 
>>>> Webrev:
>>>> http://cr.openjdk.java.net/~kbarrett/8213352/open.00/
> I think this is a really good change and generally it looks good. Just a small comments:
> src/hotspot/share/gc/shared/ptrQueue.cpp
> 148       for (size_t i = 0; i < remove; ++i, prev = tail, tail = tail->next()) {
> 149         assert(tail != NULL, "free list size is wrong");
> 150       }
> 
> I would prefer 'prev = tail, tail = tail->next()' to be in the body of the for loop to make it easier to read.

OK.

> ---
> 
> No need to see a new webrev for this and if you have a strong opinion against it go ahead and push anyways.

Thanks for reviewing.




More information about the hotspot-gc-dev mailing list