RFR: JDK-8211955: GC abstraction for LAB reserve
rkennke at redhat.com
Wed Oct 10 09:43:54 UTC 2018
Am 10. Oktober 2018 11:30:51 MESZ schrieb Aleksey Shipilev <shade at redhat.com>:
>On 10/09/2018 10:16 PM, Roman Kennke wrote:
>> virtual size_t min_dummy_object_word_size() const;
>I think the proper nomenclature would be
>min_filler_object_size_words()? We can even drop "words"
I chose 'dummy' because it relates closely to the fill_with_dummy_object() right above. And I put 'words' there to avoid the usual confusion 'is it bytes, or is it words?'
>That looks much cleaner than PLAB/TLAB hacks! Looks good to me.
Cool, thanks for reviewing! I'll post an updated webrev with min_filler_object_size() changed when I'm back from doctor appt, unless we agree on something better in the meantime.
Can you do me a favour and test this on a 32bits build? I suspect that the alignment stuff is entirely different there...
More information about the hotspot-gc-dev