RFR: 8210710: Rename ThreadLocalAllocBuffer::myThread() to thread()

Per Liden per.liden at oracle.com
Thu Sep 13 11:48:47 UTC 2018


Thanks Thomas!

/Per

On 09/13/2018 01:38 PM, Thomas Schatzl wrote:
> Hi Per,
> 
> On Thu, 2018-09-13 at 13:14 +0200, Per Liden wrote:
>> I propose that we rename ThreadLocalAllocBuffer::myThread() to
>> ThreadLocalAllocBuffer::thread(), since we typically don't do
>> camelCase naming in hotspot. I got annoyed by this when working on an
>> unrelated TLAB change, so I broke this out into a separate patch.
>>
>> Bug: https://bugs.openjdk.java.net/browse/JDK-8210710
>> Webrev: http://cr.openjdk.java.net/~pliden/8210710/webrev.0
>>
> 
>    looks good.
> 
> Thomas
> 


More information about the hotspot-gc-dev mailing list