RFR(tedious): 8218089: Rename DirtyCardQueue et al to follow usual G1 naming conventions

Kim Barrett kim.barrett at oracle.com
Fri Feb 1 06:25:18 UTC 2019


Please review this renaming of some G1-specific classes and associated
files to follow our usual naming conventions.

Renamed files:
dirtyCardQueue.[ch]pp => g1DirtyCardQueue.[ch]pp

Added "G1" prefix to class names CardTableEntryClosure,
DirtyCardQueue, and DirtyCardQueueSet.

Also did a little bit of #include list and forward declaration list
maintenance related to these changes.

CR:
https://bugs.openjdk.java.net/browse/JDK-8218089

Webrev:
http://cr.openjdk.java.net/~kbarrett/8218089/open.00/

Testing:
mach5 tier1-3



More information about the hotspot-gc-dev mailing list