RFR(tedious): 8218089: Rename DirtyCardQueue et al to follow usual G1 naming conventions
kim.barrett at oracle.com
Tue Feb 5 14:36:49 UTC 2019
> On Feb 5, 2019, at 3:49 AM, Thomas Schatzl <thomas.schatzl at oracle.com> wrote:
> Hi Kim,
> On Fri, 2019-02-01 at 01:31 -0500, Kim Barrett wrote:
>>> On Feb 1, 2019, at 1:25 AM, Kim Barrett <kim.barrett at oracle.com>
>>> Please review this renaming of some G1-specific classes and
>>> associated files to follow our usual naming conventions.
>>> Renamed files:
>>> dirtyCardQueue.[ch]pp => g1DirtyCardQueue.[ch]pp
>>> Added "G1" prefix to class names CardTableEntryClosure,
>>> DirtyCardQueue, and DirtyCardQueueSet.
>>> Also did a little bit of #include list and forward declaration list
>>> maintenance related to these changes.
>>> mach5 tier1-3
>> I forgot to mention that these changes touch a couple of S390 and PPC
>> files in fairly obvious ways. I haven’t tested those changes; they
>> look trivial, and hopefully I didn’t botch them.
> Looks good.
More information about the hotspot-gc-dev