RFR(tedious): 8218089: Rename DirtyCardQueue et al to follow usual G1 naming conventions

Leo Korinth leo.korinth at oracle.com
Wed Feb 13 11:55:08 UTC 2019


Looks good, thanks for cleaning!

Add copyright (ranges) in the files below before pushing:
src/hotspot/cpu/ppc/gc/g1/g1BarrierSetAssembler_*.cpp
src/hotspot/share/gc/g1/g1ThreadLocalData.hpp

Thanks,
Leo

On 01/02/2019 07:31, Kim Barrett wrote:
>> On Feb 1, 2019, at 1:25 AM, Kim Barrett <kim.barrett at oracle.com> wrote:
>>
>> Please review this renaming of some G1-specific classes and associated
>> files to follow our usual naming conventions.
>>
>> Renamed files:
>> dirtyCardQueue.[ch]pp => g1DirtyCardQueue.[ch]pp
>>
>> Added "G1" prefix to class names CardTableEntryClosure,
>> DirtyCardQueue, and DirtyCardQueueSet.
>>
>> Also did a little bit of #include list and forward declaration list
>> maintenance related to these changes.
>>
>> CR:
>> https://bugs.openjdk.java.net/browse/JDK-8218089
>>
>> Webrev:
>> http://cr.openjdk.java.net/~kbarrett/8218089/open.00/
>>
>> Testing:
>> mach5 tier1-3
> 
> I forgot to mention that these changes touch a couple of S390 and PPC
> files in fairly obvious ways.  I haven’t tested those changes; they look
> trivial, and hopefully I didn’t botch them.
> 
> 


More information about the hotspot-gc-dev mailing list