RFR (M): 8219747: Remove g1_ prefix to g1_remset and g1_policy members in G1CollectedHeap

Thomas Schatzl thomas.schatzl at oracle.com
Wed Feb 27 10:09:01 UTC 2019


Hi all,

  can I have reviews for this renaming change that removes some "g1_"
prefixes to some G1CollectedHeap members? They are simply unnecessary
within the context of G1.

There has also been a "g1_collector_policy" method - after looking at
its uses I decided to remove it and add a specific whitebox support
method for it to G1CollectedHeap instead.

CR:
https://bugs.openjdk.java.net/browse/JDK-8219747
Webrev:
http://cr.openjdk.java.net/~tschatzl/8219747/webrev/
Testing:
local compilation

Thanks,
  Thomas



More information about the hotspot-gc-dev mailing list