RFR (S): 8219369: Add named constants for iterating ExtRootScan phases
kim.barrett at oracle.com
Wed Feb 27 17:23:25 UTC 2019
> On Feb 27, 2019, at 4:37 AM, Thomas Schatzl <thomas.schatzl at oracle.com> wrote:
> On Tue, 2019-02-26 at 17:49 -0500, Kim Barrett wrote:
>>> On Feb 20, 2019, at 5:15 AM, Thomas Schatzl <
>>> thomas.schatzl at oracle.com> wrote:
>>> Hi all,
>>> can I have reviews for this change that has been suggested as part
>>> of another review to improve readability of the ExtRootScan sub-
>>> phase printing?
>> Looks good, but...
>> I have something of a preference against cluttering enums with such
>> pseudo-enumerators, and instead prefer class constants. But I'll
>> leave it up to you.
> Fixed in
> http://cr.openjdk.java.net/~tschatzl/8219369/webrev.0_to_1/ (diff)
> http://cr.openjdk.java.net/~tschatzl/8219369/webrev.1/ (full)
> Yeah, looks better. Thanks for making me look at this option.
> Testing: compilation.
More information about the hotspot-gc-dev