RFR: JDK-8214236: sun.gc.collector.2.name should be changed
chihiro.ito at oracle.com
Mon Jan 14 17:19:08 UTC 2019
Thank you for reviewing and giving ideas.
I agree to this idea. In addition, I think we should change also counter
names "CMS stop-the-world phases" to "CMS concurrent cycle pauses" in CMS.
On 2019/01/14 18:21, Thomas Schatzl wrote:
> On Sun, 2019-01-13 at 20:59 +0100, Per Liden wrote:
>> "G1 stop-the-world concurrent collections" sounds like a
>> Can't we find a better name for this?
>> On 01/13/2019 06:43 PM, Chihiro Ito wrote:
>>> Hi all,
>>> Fixing up name "collector.2" of G1GC in PerfCounter.print.
>>> Here is the webrev to do that:
>>> JBS: https://bugs.openjdk.java.net/browse/JDK-8214236
>>> webrev: http://cr.openjdk.java.net/~cito/JDK-8214236/webrev.00/
> "G1 concurrent cycle pauses" might be better names.
> It might be useful to look at the other names too:
> G1 incremental collections
> G1 stop-the-world full collections
> I would at least suggest to drop the "stop-the-world" since it seems
> superfluous as all collections are stw; and maybe add "pauses" to be
> similar to the above suggested "concurrent cycle pauses", i.e.
> something like
> G1 concurrent cycle pauses
> G1 incremental collection pauses
> G1 full collection pauses
> may be slightly better.
> Note that I have no idea where these names show up, so a CSR and/or
> release note may be needed.
More information about the hotspot-gc-dev