RFR (L): 8219100: Improve do_collection_pause_at_safepoint

Thomas Schatzl thomas.schatzl at oracle.com
Mon Mar 4 11:16:29 UTC 2019


Hi all,

  can I have reviews for this (relatively big) cleanup change that
reorganizes the G1CollectedHeap::do_collection_pause_at_safepoint()
method to be (imho) much more readable?

- refactored out some methods, mainly verification but also other
helpers
- grouped together "same" category calls so that e.g. collection set
related methods are not more or less randomly interspersed with
unrelated code
- moved code into the right "levels" of indentation
- moved code related to evacuation that kind of bleeded out of
pre/post_evacuate_collection_set() into it, also trying to improve
grouping and ordering

CR:
https://bugs.openjdk.java.net/browse/JDK-8219100
Webrev:
http://cr.openjdk.java.net/~tschatzl/8219100/webrev
Testing:
hs-tier1-8

Thanks,
  Thomas



More information about the hotspot-gc-dev mailing list