RFR: 8220569: ZGC: Rename and rework ZUnmapBadViews to ZVerifyViews

Stefan Karlsson stefan.karlsson at oracle.com
Wed Mar 13 12:15:54 UTC 2019


Looks good.

StefanK

On 2019-03-13 12:36, Per Liden wrote:
> The ZUnmapBadViews option is really a verification option, and should 
> follow the ZVerify* naming convention. Further, the mechanism itself 
> needs to be reworked a bit to not depend on pages being in the page 
> table when cached, in preparation for later patches that reworks the 
> ZPage life cycle.
> 
> Bug: https://bugs.openjdk.java.net/browse/JDK-8220569
> Webrev: http://cr.openjdk.java.net/~pliden/8220569/webrev.0
> 
> /Per


More information about the hotspot-gc-dev mailing list