RFR (round 2) JDK-8039525: HashTable lookup API needs refactoring
gerard.ziemski at oracle.com
Wed Apr 30 18:00:14 UTC 2014
Please review this 2nd webrev for a simple enhancement, which renames symbolTable::lookup
API using names that better reflect the method purpose, ie: lookup, lookup_and_add,
lookup_and_hash, lookup_and_add_unicode, lookup_and_hash_unicode and lookup_and_ignore_hash.
The changes since webrev 1:
Re: Christian Thalinger
Dropped the “_only” suffix completely - I decided it was no longer needed after being left
with 1 API using it (ie. lookup_only —> lookup, after dropping it first from lookup_only_and_add)
Re: John Rose
Renamed “probe” into “lookup_and_ignore_hash”. Removed “blank” lines and checked with jcheck
Re: Per Liden
Decided to leave “lookup_and_add” alone, since “lookup_or_add” implies one or the other and seems
even less right. We could have renamed “lookup_and_add” as “lookup_and_add_if_needed”,
but there is no “lookup_and_add_always”, so I simply left it alone - hope that’s OK.
Tested with hotspot jtreg, vm.quicklooks and JPRT. Locally builds on Mac OS X and Linux.
More information about the hotspot-runtime-dev