RFR(XS) 8189140 - SystemDictionaryShared::initialize() should be renamed to be more meaningful

Ioi Lam ioi.lam at oracle.com
Tue May 15 06:07:22 UTC 2018



1. Removed the forced initialization of a few classes used by AppCDS at 
JVM start-up.
    Instead, initialize these class on demand by calling 
InstanceKlass::initialize, which
    is a quick no-op if the class is already initialized.

2. The only initialization left is that of a global lock. So I renamed 
the function
    to SystemDictionaryShared::initialize_locks().

3. I moved the call of this function from 
SystemDictionary::compute_java_loaders() to
SystemDictionary::initialize() where it seems to fit.

Testing with hs-tiers 1 and 2.

- Ioi

More information about the hotspot-runtime-dev mailing list