<i18n dev> Intent to commit modifications to Character.java
Joseph D. Darcy
Joe.Darcy at Sun.COM
Wed Aug 5 09:37:56 PDT 2009
Martin Buchholz wrote:
> Hi Masayoshi,
> I was thinking "but all you have to do to get the actual value
> is follow the @link to the constant (e.g. MAX_SURROGATE)"
> but I tried that but... for example...
> does not document the hex value.
> I think *that's* where we should move the description of the hex value.
> I propose to modify my patch in that way.
> (The hex values are also documented in the Character class comment)
Yes, I agree it is perfectly reasonable and informative for the MAX_FOO
documentation to say "MAX_FOO is 0xabcd". That is the right place for
such detailed information.
In contrast, I don't find the isFoo method's documentation saying
"Returns true if c >= 0x1234 && c <= 0xabcd"
when the actual code uses the more readable
"return c >= MIN_FOO && c <= MAX_FOO"
to be kind to readers of the javadoc!
> On Tue, Aug 4, 2009 at 22:34, Masayoshi Okutsu<Masayoshi.Okutsu at sun.com> wrote:
>> Hi Martin,
>> I vaguely remember that we (jsr204) followed the convention of the Character
>> class to mention Unicode values in the API doc. It's also convenient to have
>> Unicode values because you don't need to look up the Unicode standards. I
>> don't see much value to rewrite the existing descriptions.
>> On 8/5/2009 11:03 AM, Martin Buchholz wrote:
>>> Hi i18n team,
>>> I am intending to commit these changes to java.lang.Character
>>> (follow-on change)
>>> as soon as I have CCC approval.
More information about the i18n-dev