Code Review Request for two pass signing
Alan.Bateman at oracle.com
Tue Apr 19 07:34:13 PDT 2011
Sean Mullan wrote:
> Right, but the code throws an IOException if the number of bytes
> transferred is not equal to what was requested (the 2nd argument). Are
> you suggesting it would be more accurate to use '<' since the method
> can never transfer more than requested?
I would use a loop to ensure that the entire content is transferred
rather than throwing IOException.
> This is calling the org.openjdk.jigsaw.Files.delete() utility method.
> Should I use java.nio.files.Files.delete() instead? We should really
> change the name of that class to avoid clashes with the
> java.nio.file.Files class.
Ah silly me, I couldn't figure out how it even compiled.
More information about the jigsaw-dev