Substitution (aka aliases)
Alan.Bateman at oracle.com
Thu Apr 19 05:32:20 PDT 2012
On 12/04/2012 21:28, Mandy Chung wrote:
> As for class name, I also thought about "Dictionary" while I think
> it's more like a directory of looking up names. I can change it if
> you think Dictionary is a better fit.
I don't have a strong opinion on the name, it was just a passing comment
that "ModuleDirectory" might be confused with the directories for
modules. Would "Inventory" work?
> I also like to make ModuleDirectory and also RepoList inner classes to
> extend MetaData but it requires some cleanup that I leave it for later
> to do. The current MetaData class writes to the file directly but
> what we want here to write to a temporary file first and then
> atomically replace the file so that readers of ModuleDictionary
> doesn't need to hold the exclusive lock. I keep this as one of the
> cleanup tasks to do.
Ah right, I follow you now and it can be sorted out later.
More information about the jigsaw-dev