Defining open modules and packages

Christian Frommeyer Christian.Frommeyer at
Tue Dec 6 12:00:06 UTC 2016

Hi Claes,

That's it. I just didn't realize there where different ea builds. Works now for me.

Thanks for pointing me to the solution.

Regards Christian

-----Original Message-----
From: Claes Redestad [mailto:claes.redestad at] 
Sent: Dienstag, 6. Dezember 2016 12:41
To: Christian Frommeyer <Christian.Frommeyer at>; jigsaw-dev at
Subject: Re: Defining open modules and packages

Hi Christian,

could it be that you've downloaded the regular EA build 146 rather than the jigsaw EA build 146[1]?

The changes enabling the new "open" keyword is set to appear in the regular EA builds starting from build 148 (from there on out I hope there'll be less difference between the regular EA builds and the jigsaw ones).




On 2016-12-06 12:34, Christian Frommeyer wrote:
> Hi,
> I heard a lot about jigsaw at Devoxx Belgium this year and got curious what is in the new module system for us. I downloaded ea build 146 and started to experiment. So far it was mostly straight forward. But now I'm struggeling to get open modules (and packages) to work. I tried the syntax described here:
> This is also what was presented in various talks at Devoxx. However when trying to compile the module-info file I get this error:
> Compiling... src/moduleopen/ error: class, 
> interface, or enum expected open module moduleopen { ^
> 1 error
> Unfortunately I wasn't able to find any documentation on a change in syntax. I only found this:
> which seems to be a different version of the above. But I wasn't able to match what might be the right alternative for open here. Perhaps someone can clarify this and perhaps even help with some link to documentation on this.
> Regards
> Christian Frommeyer

More information about the jigsaw-dev mailing list