SV: Supported Eclipse versions in JMC 7.1.0.

Marcus Hirt marcus at
Thu Feb 28 07:48:45 UTC 2019

Hi Christoph,

Since we do not use any 4.9.0 specific functionality, rather only 
4.9.0 specific bundle dependencies, and only from the rcp bundle,
theoretically there should not be any problem supporting running
the plug-in version in an Eclipse 4.8.0. Of course, this would 
all have to be verified, especially since we would no longer be 
able to run the automated UI tests (no more Photon profile).

Kind regards,

-----Ursprungligt meddelande-----
Från: jmc-dev <jmc-dev-bounces at> För Langer, Christoph
Skickat: den 27 februari 2019 23:38
Till: Marcus Hirt <marcus.hirt at>; jmc-dev at
Ämne: RE: Supported Eclipse versions in JMC 7.1.0.

Hi Marcus,

> So my questions are:
> * How about building JMC 7.1.0 with only Eclipse 4.9.0 or 4.10.0 as platforms?

Does that mean, what Eclipse platform versions we'll support for building the RCP package? If yes, then I think it's perfectly fine to use only the latest Eclipse versions.

> * How about using Eclipse 4.10.0 as the default platform?


> * Do we still want to support running the JMC 7.1.0 plug-ins on 4.8.0?

That's the more difficult question I guess. Can JMC be installed as a plugin to some Eclipse installation? Then we should try to support lower platform versions. However, if we were to support the 4.8.0 platform, we'd need to build the plugins against the 4.8.0 platform then, right? Doesn't that contradict to your first proposal?

Best regards

More information about the jmc-dev mailing list