Supported Eclipse versions in JMC 7.1.0.

Mario Torre neugens at
Thu Feb 28 09:52:49 UTC 2019

Hi Marcus,

We need to keep in mind that downstream packaging ability if we move
upward will be greatly reduced. I second we should support a minimum
version. We should try to move things slowly. I understand that this
only practically affect only the RCP application, but this is how JMC
is distributed in Fedora for example, and will likely be the case for
all the Linux distributions.

Having the lowest baseline does not mean we need to build with that by
default, I would be ok if upstream picks the latest Eclipse at any
given release time. To consider my pain specifically, 7.0 is not yet
officially released and it's the case that 7.1 will likely be released
shortly after that. If we change the defaults between 7.1 and 7.0 we
are asking for a platform upgrade in less than a month or so.


On Thu, Feb 28, 2019 at 8:49 AM Marcus Hirt <marcus at> wrote:
> Hi Christoph,
> Since we do not use any 4.9.0 specific functionality, rather only
> 4.9.0 specific bundle dependencies, and only from the rcp bundle,
> theoretically there should not be any problem supporting running
> the plug-in version in an Eclipse 4.8.0. Of course, this would
> all have to be verified, especially since we would no longer be
> able to run the automated UI tests (no more Photon profile).
> Kind regards,
> Marcus
> -----Ursprungligt meddelande-----
> Från: jmc-dev <jmc-dev-bounces at> För Langer, Christoph
> Skickat: den 27 februari 2019 23:38
> Till: Marcus Hirt <marcus.hirt at>; jmc-dev at
> Ämne: RE: Supported Eclipse versions in JMC 7.1.0.
> Hi Marcus,
> > So my questions are:
> > * How about building JMC 7.1.0 with only Eclipse 4.9.0 or 4.10.0 as platforms?
> Does that mean, what Eclipse platform versions we'll support for building the RCP package? If yes, then I think it's perfectly fine to use only the latest Eclipse versions.
> > * How about using Eclipse 4.10.0 as the default platform?
> Sure.
> > * Do we still want to support running the JMC 7.1.0 plug-ins on 4.8.0?
> That's the more difficult question I guess. Can JMC be installed as a plugin to some Eclipse installation? Then we should try to support lower platform versions. However, if we were to support the 4.8.0 platform, we'd need to build the plugins against the 4.8.0 platform then, right? Doesn't that contradict to your first proposal?
> Best regards
> Christoph

Mario Torre
Associate Manager, Software Engineering
Red Hat GmbH <>
9704 A60C B4BE A8B8 0F30  9205 5D7E 4952 3F65 7898

More information about the jmc-dev mailing list