Supported Eclipse versions in JMC 7.1.0.

Marcus Hirt marcus.hirt at
Thu Feb 28 11:44:50 UTC 2019

Hi Christoph,

The problem is that the dependencies from the RCP bundle will
need to look differently for supporting DS in 4.9+ vs 4.8-.

That could be solved by introducing some extra build magic 
when building 4.9, providing multiple version dependent 
manifests etc...

...but I'd like to avoid that kind of build complexity if I can.

Kind regards,

On 2019-02-28, 09:47, "Langer, Christoph" <christoph.langer at> wrote:

    Hi Marcus,
    I understand.
    So why not supporting builds with all 3 of 4.8.0, 4.9.0 and 4.10.0 and using 4.10.0 as the default? Is it just because we don't want this matrix grow too big and will we have to drop stuff given the new quarterly release cadence of Eclipse?
    Maybe we could then also have a "lower bounds" platform 4.8.0 where we support/test an rcp configuration and then skip intermediate platforms like 4.9.0 from testing?
    Best regards
    > -----Original Message-----
    > From: Marcus Hirt <marcus at>
    > Sent: Donnerstag, 28. Februar 2019 08:49
    > To: Langer, Christoph <christoph.langer at>; 'Marcus Hirt'
    > <marcus.hirt at>; jmc-dev at
    > Subject: SV: Supported Eclipse versions in JMC 7.1.0.
    > Hi Christoph,
    > Since we do not use any 4.9.0 specific functionality, rather only
    > 4.9.0 specific bundle dependencies, and only from the rcp bundle,
    > theoretically there should not be any problem supporting running
    > the plug-in version in an Eclipse 4.8.0. Of course, this would
    > all have to be verified, especially since we would no longer be
    > able to run the automated UI tests (no more Photon profile).
    > Kind regards,
    > Marcus
    > -----Ursprungligt meddelande-----
    > Från: jmc-dev <jmc-dev-bounces at> För Langer, Christoph
    > Skickat: den 27 februari 2019 23:38
    > Till: Marcus Hirt <marcus.hirt at>; jmc-dev at
    > Ämne: RE: Supported Eclipse versions in JMC 7.1.0.
    > Hi Marcus,
    > > So my questions are:
    > > * How about building JMC 7.1.0 with only Eclipse 4.9.0 or 4.10.0 as
    > platforms?
    > Does that mean, what Eclipse platform versions we'll support for building the
    > RCP package? If yes, then I think it's perfectly fine to use only the latest
    > Eclipse versions.
    > > * How about using Eclipse 4.10.0 as the default platform?
    > Sure.
    > > * Do we still want to support running the JMC 7.1.0 plug-ins on 4.8.0?
    > That's the more difficult question I guess. Can JMC be installed as a plugin to
    > some Eclipse installation? Then we should try to support lower platform
    > versions. However, if we were to support the 4.8.0 platform, we'd need to
    > build the plugins against the 4.8.0 platform then, right? Doesn't that
    > contradict to your first proposal?
    > Best regards
    > Christoph

More information about the jmc-dev mailing list